Currently experiencing elevated errors
Incident Report for Clarity Pediatrics
Resolved
This incident has been resolved.
Posted Nov 20, 2024 - 12:07 PST
Investigating
We're experiencing an elevated level of errors and are currently looking into the issue.
Posted Nov 20, 2024 - 12:06 PST
This incident affected: web-app.